System Requirements

System Requirements

Required Components

SPCAF requires the following components:

  • .NET Framework 4.0
  • Operating Systems: Windows Server 2016,2012 r2, 2003 SP2; Windows Vista SP1; Windows XP SP2 or above

Supported Products

SPCAF supports:

  • Microsoft Visual Studio 2010, 2012, 2013, 2015
  • Microsoft SharePoint 2007, 2010, 2013, 2016, SharePoint Online
  • Microsoft Team Foundation Server 2010, 2012, 2013, 2015, 2017
  • Microsoft Visual Studio Team Services (previously Visual Studio Online)
  • Build Systems which can execute PowerShell Cmdlets, MSBuild tasks or Command Line tools (e.g. TeamCity, Jenkins, Atlassian Bamboo)
  • Gulp - SharePoint Framework projects only
  • Visual Studio Code - SharePoint Framework projects only
  • SPCAF Yeoman generator required for Gulp & Visual Studio Code

To analyze in the SPCAF standalone client application, neither SharePoint, Visual Studio nor the source code of the solution/app are required.

Included Open-Source Libraries

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.