Could not load file or assembly 'System.xxx, Version=2.0.5.0'

Error Message

Message: Failed to load settings file 'C:\Program Files x86)\SPCAF\RuleSets\RS10_ExtendedRecommendedRules.sp...


Stacktrace: Failed to load settings file 'C:\Program Files (x86)\SPCAF\RuleSets\RS10_ExtendedRecommendedRules.spruleset'!

Could not load file or assembly 'System.Xml, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e, Retargetable=Yes' or one of its dependencies.

 

Problem

This issue occurs when the installed .NET version is not patched with the most current version.
SPCAF uses portable class libraries to enable other tools to load SPCAF results which require a patched .NET Framework.

See similar issue of others here: http://stackoverflow.com/questions/23903657/could-not-load-file-or-assembly-system-version-2-0-5-0-in-net-4-mvc-4-applicat

 

Resolution

Make sure your .NET framework is patched.

Microsoft released patches to .NET to allow Portable Class Libraries to properly find the appropriate runtime (KB2468871). If you are seeing the above exception (or something like it e.g. System.Core), it means you're missing the latest .NET framework patches.

Either run a Windows Update to retrieve the latest patches, install the latest Visual Studio Update (in case you have Visual Studio on the machine) or Silverlight 5 SDK as described here.

 

 

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.